Start a new topic

Incoming calls fail to ring intermittently

I have:


a) a linksys pap2 with two lines configured in mini-pbx mode. Both online per pap2

b) two pots lines

c) google voice configured  with all the above to ring on incoming calls.


Outgoing calls work fine. Incoming calls fail to ring intermittently (approx50%) on the two linksys lines and never fail on the Pots lines. Google voice settings remain the same between working incoming calls and non working incoming calls.


Any help appreciated!




Setting the registration timer lower, enabling NAT Keepalive, or using SIP over TCP should help solve problems like this, usually caused by your NAT router blocking the incoming call connection.

If I am not mistaken you use DNS_SRV records and doesn't this mean that his ATA may be rejecting a call that is not coming from the IP e registered to? He should not restrict calls to the proxy address and enable DNS_SRV.

I am seeing this same problem with my Grandstream GXP1405. I have the registration timeouts pretty low, enabled keep alive. I see the same issue whether or not I am using UDP or TCP. Would be nice to have a configuration how to for all possible settings (recommended values.


I have recently noticed the same on asterisk as well. I normally have asterisk answer the call and play fake ring back so I do not have to deal with google voice mail. Lately howver I have received some google voice mails meaning the call never made it to asterisk or was rejected. . I am using the recommended asterisk configuration published in the how to section here with asterisk 11.x
Also my asterisk is on a public IP directly so NAT is not the issue

HI. Is anyone looking into this. I am on a NAT gateway, but I doubt that is the problem. My other VOIP services work without an issue.


I am using a Grandstream GXP1405 phone. I see the same issue whether I am using UDP, TCP, or TCP/TLS.


I am willing to help debug this problem if I can find someone from the gateway side to work with me.


Mark, review your Asterisk logs to see whether Asterisk picked up the call. If Asterisk thinks it answered the call but you find that it still went to Google Voice voicemail, then GV wasn't "convinced" by your fake ringback tone. (This has typically worked fine in the past, but may not be as effective now.) If the call didn't hit Asterisk, then there's a different problem.


Gregg, if you can provide timestamps and caller ID for when the calls were not sent to your phone, then it is easy to look those up on the gateway and determine what happened to the call.

Bill - I tried to make a few calls to my google number that didn't ring on my phone. I am currently using TCP/TLS for SIP, so please let me know if this is an issue.


I made calls at:


Mon Jul 31 08:40:31 EDT 2017 and

Mon Jul 31 08:40:57 EDT 2017


Timestamps are approximate (within a few seconds).



Bill - I just switched to UDP and incoming calls started working again. They will stop working within the next day. I will let you know when I stop receiving calls again.



Gregg, per call detail records, your test calls reached the gateway and then failed due to "No route to call target" - typically meaning your equipment wasn't SIP-registered at that time.

Bill,


Thanks for looking into this. I checked my device at the time and it believes it is registered. It re-registers every 10 minutes (expiration is 10 minutes). I tried setting the expiration to 10 minutes but it doesn't make a difference.


Any thoughts on how to debug this further? I have a pretty much standard grandstream device configuration.




I recently sent the configuration for a PAP2T to Simonics here to post. As I recall near the top of the configuration just make sure you have NAT Mapping enable , Yes and NAT Keep Alive enable Yes.  ALso make sure you have outbound proxy enanabled and set to gvgw.simonics.com. Also on another page at the bottom NO STUN SERVER.


I do not think you can use stun and outbound proxy at the same time.


Maybe bill will post what I sent him for the PAP2T???

@mark dm - have phone configured as best as possible. NAT turned with keep alives. Phone thinks it is registered and is getting successful response from re-registrations after registration expiration. Bill reports that calls fail because device is not registered. Everything looks correct from this side. I am really surprised this doesn't work. I have VOIP service from two other providers and I don't have this issue.


Any thoughts? Would be nice to have GV working with my phone, but alas it does not.

I wanted to update this thread. 


Although Bill did point out some errors that I had made in my configuration, those were recent changes which were undone, and  although I did follow his advice I still have calls go to Google  Voice mail , but only once in a while.


I do believe this is an on-going issue

Login or Signup to post a comment